Allows the caller to set the calculated value for a specified cell
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetCellCalculatedValue( int nRow, int nCol, TableCellCalculatedValueData pCalcValue ) |
Visual Basic |
---|
Public Sub SetCellCalculatedValue ( _ nRow As Integer, _ nCol As Integer, _ pCalcValue As TableCellCalculatedValueData _ ) |
Visual C++ |
---|
public: void SetCellCalculatedValue( int nRow, int nCol, TableCellCalculatedValueData^ pCalcValue ) |
Parameters
- nRow
- Type: System..::..Int32
- nCol
- Type: System..::..Int32
- pCalcValue
- Type: Autodesk.Revit.DB..::..TableCellCalculatedValueData
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule header sections. -or- This operation is forbidden for cells in standard schedule body sections. |