Identifies if the indicated end of the framing element is allowed to join to others.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public static bool IsJoinAllowedAtEnd(
FamilyInstance familyInstance,
int end
) |
Visual Basic |
---|
Public Shared Function IsJoinAllowedAtEnd ( _
familyInstance As FamilyInstance, _
end As Integer _
) As Boolean |
Visual C++ |
---|
public:
static bool IsJoinAllowedAtEnd(
FamilyInstance^ familyInstance,
int end
) |
Parameters
- familyInstance
- Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance, which must be of a structural framing category.
- end
- Type: System..::..Int32
The index of the end (0 for the start, 1 for the end).
Return Value
True if it is allowed to join. False if it is disallowed.
Exceptions
See Also