StructuralFramingUtilsIsJoinAllowedAtEnd Method |
Identifies if the indicated end of the framing element is allowed to join to others.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsJoinAllowedAtEnd(
FamilyInstance familyInstance,
int end
)
Public Shared Function IsJoinAllowedAtEnd (
familyInstance As FamilyInstance,
end As Integer
) As Boolean
public:
static bool IsJoinAllowedAtEnd(
FamilyInstance^ familyInstance,
int end
)
static member IsJoinAllowedAtEnd :
familyInstance : FamilyInstance *
end : int -> bool
Parameters
- familyInstance FamilyInstance
-
The FamilyInstance, which must be of a structural framing category.
- end Int32
-
The index of the end (0 for the start, 1 for the end).
Return Value
Boolean
True if it is allowed to join. False if it is disallowed.
Exceptions
See Also