The ExternalCommandData type exposes the following members.

Methods

  NameDescription
Public methodDispose
Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject.)
Public methodEquals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public methodGetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public methodGetType
Gets the Type of the current instance.
(Inherited from Object.)
Public methodToString
Returns a string that represents the current object.
(Inherited from Object.)

Properties

  NameDescription
Public propertyApplication
Retrieves an object that represents the current Application for external command.
Public propertyIsReadOnly
Identifies if the object is read-only or modifiable.
(Inherited from APIObject.)
Public propertyJournalData
A data map that can be used to read and write data to the Autodesk Revit journal file.
Public propertyView
Retrieves an object that represents the View external command work on.

See Also