Constructs a new instance of a filter to match elements which are owned by a particular view,
with the option to invert the filter and find elements not owned by the given view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ElementOwnerViewFilter(
ElementId viewId,
bool inverted
) |
Visual Basic |
---|
Public Sub New ( _
viewId As ElementId, _
inverted As Boolean _
) |
Visual C++ |
---|
public:
ElementOwnerViewFilter(
ElementId^ viewId,
bool inverted
) |
Parameters
- viewId
- Type: Autodesk.Revit.DB..::..ElementId
The view id to match.
Pass invalid element id to create a filter that will pass non-view-specific elements.
- inverted
- Type: System..::..Boolean
True if the filter should match all elements which are not owned by the given view.
Exceptions
See Also