ElementOwnerViewFilter(ElementId, Boolean) Constructor |
Constructs a new instance of a filter to match elements which are owned by a particular view,
with the option to invert the filter and find elements not owned by the given view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementOwnerViewFilter(
ElementId viewId,
bool inverted
)
Public Sub New (
viewId As ElementId,
inverted As Boolean
)
public:
ElementOwnerViewFilter(
ElementId^ viewId,
bool inverted
)
new :
viewId : ElementId *
inverted : bool -> ElementOwnerViewFilter
Parameters
- viewId ElementId
-
The view id to match.
Pass invalid element id to create a filter that will pass non-view-specific elements.
- inverted Boolean
-
True if the filter should match all elements which are not owned by the given view.
Exceptions
See Also