Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public ElementMulticategoryFilter(
	ICollection<ElementId> categoryIds,
	bool inverted
)
Visual Basic
Public Sub New ( _
	categoryIds As ICollection(Of ElementId), _
	inverted As Boolean _
)
Visual C++
public:
ElementMulticategoryFilter(
	ICollection<ElementId^>^ categoryIds, 
	bool inverted
)

Parameters

categoryIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The category ids to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given categories.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException One or more categories was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also