ElementMulticategoryFilter(ICollectionElementId, Boolean) Constructor |
Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementMulticategoryFilter(
ICollection<ElementId> categoryIds,
bool inverted
)
Public Sub New (
categoryIds As ICollection(Of ElementId),
inverted As Boolean
)
public:
ElementMulticategoryFilter(
ICollection<ElementId^>^ categoryIds,
bool inverted
)
new :
categoryIds : ICollection<ElementId> *
inverted : bool -> ElementMulticategoryFilter
Parameters
- categoryIds ICollectionElementId
-
The category ids to match.
- inverted Boolean
-
True if the filter should match all elements which are not of the given categories.
Exceptions
See Also