Constructs the transformation by specifying the vectors and the origin.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public Transform2D( UV uVec, UV vVec, UV origin ) |
Visual Basic |
---|
Public Sub New ( _ uVec As UV, _ vVec As UV, _ origin As UV _ ) |
Visual C++ |
---|
public: Transform2D( UV^ uVec, UV^ vVec, UV^ origin ) |
Parameters
- uVec
- Type: Autodesk.Revit.DB..::..UV
The image of (1, 0) under OfVector(UV).
- vVec
- Type: Autodesk.Revit.DB..::..UV
The image of (0, 1) under OfVector(UV).
- origin
- Type: Autodesk.Revit.DB..::..UV
The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |