Determines if the input wall is completely removed by interaction with other elements
within the given range.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool IsWallCompletelyClipped( Wall pVWall, ExporterIFC exporterIFC, IFCRange range ) |
Visual Basic |
---|
Public Shared Function IsWallCompletelyClipped ( _ pVWall As Wall, _ exporterIFC As ExporterIFC, _ range As IFCRange _ ) As Boolean |
Visual C++ |
---|
public: static bool IsWallCompletelyClipped( Wall^ pVWall, ExporterIFC^ exporterIFC, IFCRange^ range ) |
Parameters
- pVWall
- Type: Autodesk.Revit.DB..::..Wall
The wall.
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
- range
- Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.
Return Value
True if the wall should be ignored within the given range.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |