Fix the direction of a segment.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetSegmentFixedDirection(
int iSegment,
double vecCoordX,
double vecCoordY
) |
Visual Basic |
---|
Public Sub SetSegmentFixedDirection ( _
iSegment As Integer, _
vecCoordX As Double, _
vecCoordY As Double _
) |
Visual C++ |
---|
public:
void SetSegmentFixedDirection(
int iSegment,
double vecCoordX,
double vecCoordY
) |
Parameters
- iSegment
- Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
- vecCoordX
- Type: System..::..Double
The x-coordinate of a 2D vector specifying the segment direction.
- vecCoordY
- Type: System..::..Double
The y-coordinate of a 2D vector specifying the segment direction.
Remarks
Exceptions
See Also