RebarShapeDefinitionBySegmentsSetSegmentFixedDirection Method |
Fix the direction of a segment.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetSegmentFixedDirection(
int iSegment,
double vecCoordX,
double vecCoordY
)
Public Sub SetSegmentFixedDirection (
iSegment As Integer,
vecCoordX As Double,
vecCoordY As Double
)
public:
void SetSegmentFixedDirection(
int iSegment,
double vecCoordX,
double vecCoordY
)
member SetSegmentFixedDirection :
iSegment : int *
vecCoordX : float *
vecCoordY : float -> unit
Parameters
- iSegment Int32
-
Index of the segment (0 to NumberOfSegments - 1).
- vecCoordX Double
-
The x-coordinate of a 2D vector specifying the segment direction.
- vecCoordY Double
-
The y-coordinate of a 2D vector specifying the segment direction.
ExceptionsException | Condition |
---|
ArgumentException |
iSegment is not between 0 and NumberOfSegments.
-or-
The length of the vector (vecCoordX, vecCoordY) is too close to zero.
|
Remarks
The centerline of the segment will be constrained to be parallel to the vector. The segment must have at least one constraint.
See Also