Manipulates the vertex on the corresponding slab, roof or floor.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void ModifySubElement( SlabShapeVertex vertex, double offset ) |
Visual Basic |
---|
Public Sub ModifySubElement ( _ vertex As SlabShapeVertex, _ offset As Double _ ) |
Visual C++ |
---|
public: void ModifySubElement( SlabShapeVertex^ vertex, double offset ) |
Parameters
- vertex
- Type: Autodesk.Revit.DB..::..SlabShapeVertex
The vertex.
- offset
- Type: System..::..Double
The new value of the vertex offset.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the vertex is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the vertex is invalid. |