Determines the bending diameter of the wire.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public double BendDiameter { get; set; } |
Visual Basic |
---|
Public Property BendDiameter As Double Get Set |
Visual C++ |
---|
public: property double BendDiameter { double get (); void set (double value); } |
Field Value
The value should be positive.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for bendDiameter is not a number |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The bending diameter bendDiameter is negative. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |