The measurement type determines how distances are calculated.
Either along a straight line between two points ('ChordLength')
or along the segment of the path that connects them. ('SegmentLength').
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public DividedPathMeasurementType MeasurementType { get; set; } |
Visual Basic |
---|
Public Property MeasurementType As DividedPathMeasurementType Get Set |
Visual C++ |
---|
public: property DividedPathMeasurementType MeasurementType { DividedPathMeasurementType get (); void set (DividedPathMeasurementType value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Invalid measurementType -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration |