DividedPathMeasurementType Property

The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DividedPathMeasurementType MeasurementType { get; set; }

Property Value

DividedPathMeasurementType
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: Invalid measurementType -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also