Checks whether the specified element can be used as a host for the railing.
The host can be:
- stairs
- stairs component
- ramp
- floor
- slab edge
- wall
- roof
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
C# |
---|
public bool RailingCanBeHostedByElement(
ElementId hostId
) |
Visual Basic |
---|
Public Function RailingCanBeHostedByElement ( _
hostId As ElementId _
) As Boolean |
Visual C++ |
---|
public:
bool RailingCanBeHostedByElement(
ElementId^ hostId
) |
Return Value
True if the element can be used as host for the railing.
Exceptions
See Also