Select a new printer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SelectNewPrintDriver( string strPrinterName ) |
Visual Basic |
---|
Public Sub SelectNewPrintDriver ( _ strPrinterName As String _ ) |
Visual C++ |
---|
public: void SelectNewPrintDriver( String^ strPrinterName ) |
Parameters
- strPrinterName
- Type: System..::..String
The name string of new printer.
Remarks
This property is the global print setting property for all documents.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-strPrinterName-is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the assigned new printer is invalid, or the print resource is occupied by others. |