The id of the material assigned to wires.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public ElementId Material { get; set; }
Visual Basic
Public Property Material As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ Material {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException When setting this property: The sheetMaterial cannot map to a valid material element.
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.

See Also