Return a reference to one of the segments in the definition.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public RebarShapeSegment GetSegment( int segmentIndex ) |
Visual Basic |
---|
Public Function GetSegment ( _ segmentIndex As Integer _ ) As RebarShapeSegment |
Visual C++ |
---|
public: RebarShapeSegment^ GetSegment( int segmentIndex ) |
Parameters
- segmentIndex
- Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
Return Value
The requested segment.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | segmentIndex is not between 0 and NumberOfSegments. |