Part of a RebarShapeDefinitionBySegments, representing one segment
of a shape definition.
Makes sure constraints of type RebarShapeConstraintFixedSegmentDir are uniquely set.
If we try to aquire a second constraint of type RebarShapeConstraintFixedSegmentDir we delete the old one.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public class RebarShapeSegment : IDisposable |
Visual Basic |
---|
Public Class RebarShapeSegment _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarShapeSegment : IDisposable |
Remarks
Each segment must have enough constraints to determine its position. Overconstraining is allowed. The most common combinations are:
- A fixed direction together with a parallel length constraint;
- A parallel length constraint plus another length constraint parallel to the x-axis or y-axis;
- A parallel length constraint plus length constraints parallel to both the x-axis and y-axis.
Length constraints may be measured in two ways. For "measured to the outside of the bend," the reference is a tangent to the exterior face of the bar; the thickness of the bar is included. For "measured to the inside," the reference is the center of the arc of the bend; this is the point where the bend begins, if the constraint is parallel to the segment.
A 180-degree bend is described by introducing a short segment in between the two straight segments, tangent to the midpoint of the bend.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeSegment
Autodesk.Revit.DB.Structure..::..RebarShapeSegment