Remove the material painted on the element's face.
If the face is currently not painted,it will do nothing.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void RemovePaint( ElementId elementId, Face face ) |
Visual Basic |
---|
Public Sub RemovePaint ( _ elementId As ElementId, _ face As Face _ ) |
Visual C++ |
---|
public: void RemovePaint( ElementId^ elementId, Face^ face ) |
Parameters
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
The element that the painted face belongs to.
- face
- Type: Autodesk.Revit.DB..::..Face
The painted element's face.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |