Sets a cell's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public void SetCellParamIdAndCategoryId(
	int nRow,
	int nCol,
	ElementId paramId,
	ElementId categoryId
)
Visual Basic
Public Sub SetCellParamIdAndCategoryId ( _
	nRow As Integer, _
	nCol As Integer, _
	paramId As ElementId, _
	categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
	int nRow, 
	int nCol, 
	ElementId^ paramId, 
	ElementId^ categoryId
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
paramId
Type: Autodesk.Revit.DB..::..ElementId
categoryId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The paramId or categoryId is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also