TableSectionDataSetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) Method |
Sets a cell's category and parameter Id
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetCellParamIdAndCategoryId(
int nRow,
int nCol,
ElementId paramId,
ElementId categoryId
)
Public Sub SetCellParamIdAndCategoryId (
nRow As Integer,
nCol As Integer,
paramId As ElementId,
categoryId As ElementId
)
public:
void SetCellParamIdAndCategoryId(
int nRow,
int nCol,
ElementId^ paramId,
ElementId^ categoryId
)
member SetCellParamIdAndCategoryId :
nRow : int *
nCol : int *
paramId : ElementId *
categoryId : ElementId -> unit
Parameters
- nRow Int32
-
- nCol Int32
-
- paramId ElementId
-
- categoryId ElementId
-
ExceptionsException | Condition |
---|
ArgumentException |
The given row number nRow is invalid.
-or-
The given column number nCol is invalid.
-or-
The paramId or categoryId is not valid.
|
ArgumentNullException |
A non-optional argument was null
|
See Also