The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public string ClassName { get; set; }
Visual Basic
Public Property ClassName As String
	Get
	Set
Visual C++
public:
property String^ ClassName {
	String^ get ();
	void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullExceptionThrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentExceptionThrown when setting the value to an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationExceptionThrown when setting the value to a ToggleButton which is not initialized with an external command.

See Also