Remove the parameter from the definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2009

Syntax

C#
public void RemoveParameter(
	ElementId paramId
)
Visual Basic
Public Sub RemoveParameter ( _
	paramId As ElementId _
)
Visual C++
public:
void RemoveParameter(
	ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.

Remarks

If the definition does not have the parameter, the method does nothing.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also