Return a transform representing the relative position of the coupler at index couplerPositionIndex in the set.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
C# |
---|
public Transform GetCouplerPositionTransform(
int couplerPositionIndex
) |
Visual Basic |
---|
Public Function GetCouplerPositionTransform ( _
couplerPositionIndex As Integer _
) As Transform |
Visual C++ |
---|
public:
Transform^ GetCouplerPositionTransform(
int couplerPositionIndex
) |
Parameters
- couplerPositionIndex
- Type: System..::..Int32
An index between 0 and (CouplerQuantity-1).
Return Value
Returns a transformation that is composed from :
- a translation from (0, 0, 0) to coupler origin
- a rotation that will align the coupler with the bar segment on which it stays.
Exceptions
See Also