RebarCouplerGetCouplerPositionTransform Method |
Return a transform representing the relative position of the coupler at index couplerPositionIndex in the set.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform GetCouplerPositionTransform(
int couplerPositionIndex
)
Public Function GetCouplerPositionTransform (
couplerPositionIndex As Integer
) As Transform
public:
Transform^ GetCouplerPositionTransform(
int couplerPositionIndex
)
member GetCouplerPositionTransform :
couplerPositionIndex : int -> Transform
Parameters
- couplerPositionIndex Int32
-
An index between 0 and (CouplerQuantity-1).
Return Value
Transform
Returns a transformation that is composed from :
- a translation from (0, 0, 0) to coupler origin
- a rotation that will align the coupler with the bar segment on which it stays.
Exceptions
See Also