Loads only a specified family type/symbol from a family file into the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool LoadFamilySymbol(
string filename,
string name
) |
Visual Basic |
---|
Public Function LoadFamilySymbol ( _
filename As String, _
name As String _
) As Boolean |
Visual C++ |
---|
public:
bool LoadFamilySymbol(
String^ filename,
String^ name
) |
Parameters
- filename
- Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
- name
- Type: System..::..String
The name of the type/symbol to be loaded, such as "W11x14".
Return Value
True if the family type/symbol was loaded successfully into the project, otherwise False.
Remarks
Exceptions
See Also