DocumentLoadFamilySymbol(String, String) Method |
Loads only a specified family type/symbol from a family file into the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool LoadFamilySymbol(
string filename,
string name
)
Public Function LoadFamilySymbol (
filename As String,
name As String
) As Boolean
public:
bool LoadFamilySymbol(
String^ filename,
String^ name
)
member LoadFamilySymbol :
filename : string *
name : string -> bool
Parameters
- filename String
- The fully qualified filename of the Family file, usually ending in .rfa.
- name String
- The name of the type/symbol to be loaded, such as "W11x14".
Return Value
BooleanTrue if the family type/symbol was loaded successfully into the project, otherwise False.
Exceptions
RemarksThis function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.
See Also