Identifies if a hook type is permitted for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public void SetHookPermission(
	ElementId hookId,
	bool permission
)
Visual Basic
Public Sub SetHookPermission ( _
	hookId As ElementId, _
	permission As Boolean _
)
Visual C++
public:
void SetHookPermission(
	ElementId^ hookId, 
	bool permission
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
permission
Type: System..::..Boolean
True if the hook type should be permitted for this bar type, otherwise false

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also