Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static void AddTrigger( UpdaterId id, ElementFilter filter, ChangeType change ) |
Visual Basic |
---|
Public Shared Sub AddTrigger ( _ id As UpdaterId, _ filter As ElementFilter, _ change As ChangeType _ ) |
Visual C++ |
---|
public: static void AddTrigger( UpdaterId^ id, ElementFilter^ filter, ChangeType^ change ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater that trigger should be added to
- filter
- Type: Autodesk.Revit.DB..::..ElementFilter
Element filter that defines elements that affect this trigger
- change
- Type: Autodesk.Revit.DB..::..ChangeType
ChangeType associated with this trigger
Remarks
This method only works with CategoryFilter and ParameterFilter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- The id does not correspond to any registered Updaters. -or- AddTrigger called while executing an updater. |