An object that stores and manages all updaters registered in the current session.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public class UpdaterRegistry : IDisposable |
Visual Basic |
---|
Public Class UpdaterRegistry _ Implements IDisposable |
Visual C++ |
---|
public ref class UpdaterRegistry : IDisposable |
Remarks
The registry is an application-wide singleton. It maintains all dynamic updaters currently registered, and also invokes them per their respective trigger condition during subsequent transactions.
Please note that only the application (an add-in, typically) which registered an updater is allowed to modify it later, including unregistering it. Also, an application is not allowed to register an updater with an Id, that is based on another application's Id.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..UpdaterRegistry
Autodesk.Revit.DB..::..UpdaterRegistry