Gets the Element object (either Host or Rebar) which provides the constraint. Will throw exception if it's a multi target constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
public Element GetTargetElement()
Visual Basic
Public Function GetTargetElement As Element
Visual C++
public:
Element^ GetTargetElement()

Return Value

Returns the Element object (either Host or Rebar) which provides the constraint.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..InvalidOperationException RebarConstraint is no longer valid. -or- Multi target constraint. Consider using the indexed version of the method.

See Also