RebarConstraintGetTargetElement Method |
Gets the Element object (either Host or Rebar) which provides the constraint.
Will throw exception if it's a multi target constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Element GetTargetElement()
Public Function GetTargetElement As Element
public:
Element^ GetTargetElement()
member GetTargetElement : unit -> Element
Return Value
Element
Returns the Element object (either Host or Rebar) which provides the constraint.
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
Multi target constraint. Consider using the indexed version of the method.
-or-
The RebarConstraint should not be of RebarConstraintType 'ToSurface'.
|
See Also