Inserts multiple IndexPoint instances into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public void AddPoints(
	IList<IndexPoint> points
)
Visual Basic
Public Sub AddPoints ( _
	points As IList(Of IndexPoint) _
)
Visual C++
public:
void AddPoints(
	IList<IndexPoint^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'IndexPoint>)>)>
The points to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also