The actual depth of the stairs treads in the stairs, actual tread depth is equal to minimum tread depth by default.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public double ActualTreadDepth { get; set; } |
Visual Basic |
---|
Public Property ActualTreadDepth As Double Get Set |
Visual C++ |
---|
public: property double ActualTreadDepth { double get (); void set (double value); } |
Remarks
In a multistory stairs, all the stairs elements keep the same tread depth parameter value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for actualTreadDepth must be greater than 0 and no more than 30000 feet. |