MultistoryStairsActualTreadDepth Property |
The actual depth of the stairs treads in the stairs, actual tread depth is equal to minimum tread depth by default.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double ActualTreadDepth { get; set; }
Public Property ActualTreadDepth As Double
Get
Set
public:
property double ActualTreadDepth {
double get ();
void set (double value);
}
member ActualTreadDepth : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: The given value for actualTreadDepth must be greater than 0 and no more than 30000 feet.
|
Remarks
In a multistory stairs, all the stairs elements keep the same tread depth parameter value.
See Also