Returns the offset from the center of the compound structure to the given location line value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double GetOffsetForLocationLine( WallLocationLine wallLocationLine ) |
Visual Basic |
---|
Public Function GetOffsetForLocationLine ( _ wallLocationLine As WallLocationLine _ ) As Double |
Visual C++ |
---|
public: double GetOffsetForLocationLine( WallLocationLine wallLocationLine ) |
Parameters
- wallLocationLine
- Type: Autodesk.Revit.DB..::..WallLocationLine
The alignment type of the wall's location line.
Return Value
The offset.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically homogeneous compound structures. |