Identifies the time interval between animation frames.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public SunStudyTimeInterval TimeInterval { get; set; } |
Visual Basic |
---|
Public Property TimeInterval As SunStudyTimeInterval Get Set |
Visual C++ |
---|
public: property SunStudyTimeInterval TimeInterval { SunStudyTimeInterval get (); void set (SunStudyTimeInterval value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the time interval value interval is not valid for the current SunAndShadowType. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |