Checks whether the given vendor ID string is valid. A valid vendor ID string:
1. Has a length of at least 4 characters and no more than 253 characters, and
2. Contains only letters, digits, or any of the following special characters:
! " # & \ ( ) + , . - : ; < = > ? _ ` | ~
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
C# |
---|
public static bool VendorIdIsValid(
string vendorId
) |
Visual Basic |
---|
Public Shared Function VendorIdIsValid ( _
vendorId As String _
) As Boolean |
Visual C++ |
---|
public:
static bool VendorIdIsValid(
String^ vendorId
) |
Parameters
- vendorId
- Type: System..::..String
The vendor ID to check.
Return Value
True if the vendor ID is valid.
Exceptions
See Also