SchemaBuilderVendorIdIsValid Method |
Checks whether the given vendor ID string is valid. A valid vendor ID string:
1. Has a length of at least 4 characters and no more than 253 characters, and
2. Contains only letters, digits, or any of the following special characters:
! " # & \ ( ) + , . - : ; < = > ? _ ` | ~
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool VendorIdIsValid(
string vendorId
)
Public Shared Function VendorIdIsValid (
vendorId As String
) As Boolean
public:
static bool VendorIdIsValid(
String^ vendorId
)
static member VendorIdIsValid :
vendorId : string -> bool
Parameters
- vendorId String
-
The vendor ID to check.
Return Value
Boolean
True if the vendor ID is valid.
Exceptions
See Also