Checks if the elements are not serially connected.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2019

Syntax

C#
public static bool AreElementsNotConnectedInSeries(
	Document document,
	ISet<ElementId> elemIds
)
Visual Basic
Public Shared Function AreElementsNotConnectedInSeries ( _
	document As Document, _
	elemIds As ISet(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AreElementsNotConnectedInSeries(
	Document^ document, 
	ISet<ElementId^>^ elemIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document of these elements.
elemIds
Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
The element ids to be tested.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also