Returns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached. The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover.' Will throw exception if it's a multi target constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
public RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType()
Visual Basic
Public Function GetRebarConstraintTargetHostFaceType As RebarConstraintTargetHostFaceType
Visual C++
public:
RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType()

Return Value

Returns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover.' -or- Multi target constraint. Consider using the indexed version of the method.

See Also