RebarConstraintGetRebarConstraintTargetHostFaceType Method |
Returns the RebarConstraintTargetHostFaceType of the host Element face to which
the RebarConstraint is attached. The RebarConstraintType of the RebarConstraint
must be 'FixedDistanceToHostFace' or 'ToCover'.
Will throw exception if it's a multi target constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType()
Public Function GetRebarConstraintTargetHostFaceType As RebarConstraintTargetHostFaceType
public:
RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType()
member GetRebarConstraintTargetHostFaceType : unit -> RebarConstraintTargetHostFaceType
Return Value
RebarConstraintTargetHostFaceType
Returns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached.
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover'.
-or-
Multi target constraint. Consider using the indexed version of the method.
|
See Also