Determines the diameter of the wire.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public double WireDiameter { get; set; } |
Visual Basic |
---|
Public Property WireDiameter As Double Get Set |
Visual C++ |
---|
public: property double WireDiameter { double get (); void set (double value); } |
Field Value
The value should be positive and less than 12 inches/300 mm.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for wireDiameter is not a number |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The wire diameter wireDiameter is negative or greater than 12 inches/300 mm. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |