Specify a parameter to drive the arc length of the shape.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2009
Syntax
C# |
---|
public void AddConstraintArcLength(
ElementId paramId
) |
Visual Basic |
---|
Public Sub AddConstraintArcLength ( _
paramId As ElementId _
) |
Visual C++ |
---|
public:
void AddConstraintArcLength(
ElementId^ paramId
) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint.
To obtain the id of a shared parameter,
call RebarShape.GetElementIdForExternalDefinition().
Exceptions
See Also