Checks whether the input name is valid for a non-continuous rail in its associated railing type.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public bool IsValidNonContinuousRailName( string name ) |
Visual Basic |
---|
Public Function IsValidNonContinuousRailName ( _ name As String _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidNonContinuousRailName( String^ name ) |
Parameters
- name
- Type: System..::..String
The name to be checked.
Return Value
True if the name is unique for the [!:Autodesk::Revit::DB::Architecture::RailingType], false otherwise.
Remarks
The name must be unique within the [!:Autodesk::Revit::DB::Architecture::RailingType]
to which the non-continuous rail belongs.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |