NonContinuousRailInfoIsValidNonContinuousRailName Method |
Checks whether the input name is valid for a non-continuous rail in its associated railing type.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidNonContinuousRailName(
string name
)
Public Function IsValidNonContinuousRailName (
name As String
) As Boolean
public:
bool IsValidNonContinuousRailName(
String^ name
)
member IsValidNonContinuousRailName :
name : string -> bool
Parameters
- name String
-
The name to be checked.
Return Value
Boolean
True if the name is unique for the
[!:Autodesk::Revit::DB::Architecture::RailingType], false otherwise.
Exceptions
Remarks
The name must be unique within the [!:Autodesk::Revit::DB::Architecture::RailingType]
to which the non-continuous rail belongs.
See Also