Checks whether input hub is valid for an AnalyticalLink.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static bool IsValidHub( Document doc, ElementId hubId ) |
Visual Basic |
---|
Public Shared Function IsValidHub ( _ doc As Document, _ hubId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsValidHub( Document^ doc, ElementId^ hubId ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
Hubs's document.
- hubId
- Type: Autodesk.Revit.DB..::..ElementId
Hub to test for validity.
Return Value
True is returned when provided hubId points hub that is valid for AnalyticalLink, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |